Submit a ticket My Tickets
Welcome
Login  Sign up

How to troubleshoot the home hub?

If there are issues with the home hub, there are a few things you can try.


First of all, make sure the home hub is fully plugged in and powered on. 


If the home hub is powered on, the various LEDs on the top will show various states, and alert to potential problems:


  • The default state of the powered-up home hub up and running, the circle LED will be on steady in green.


  • During an update of the software, the LED will blink rapidly in red.


  • During the initial start-up of the home hub (after just being plugged in for example), the circle LED will blink every second in green.


  • If the home hub is disconnected (i.e. due to 4G or signal connectivity issues) the circle LED will be off.



If the home hub is experiencing connectivity issues, you can first check the EE coverage map for any problems in your local area.


If there are further connectivity issues, it can be worth testing different locations within the home that may have better 4G connectivity. This can be tested by choosing a location within the home that has good mobile phone connectivity for example. Sometimes placing the home hub higher up, on a shelf, or window-sill can help in these situations. Also, you can try placing the home hub upright, so that the power cable is coming out of the top of it, as the main antenna is located along this side.

S
Swanny is the author of this solution article.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.